View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
10973Feature requestsOtherpublic2022-05-23 09:11
Reporterqualitatuvic Assigned To 
PrioritynoneSeverityfeature 
Status newResolutionopen 
Summary10973: Default hide tip (in advanced settings of a question)
Description

I propose an improvement on a default hide tip option. Now, the default option for the 'hide tip' on advanced settings is 'no' for any quesitons. But most times this configuration option should be 'yes', and is necessary to change it to 'yes' manually every time you create a new question in a survey.
Then, is possible to change the default option to 'yes' for a 'hide tip' in advanced settings of a question?

Additional Information

application/helpers/common_helper.php:3090

TagsNo tags attached.
Bug heat8

Relationships

related to 14248 acknowledged Allow survey theme to add (and use) question attribute 

Users monitoring this issue

User List ecoplan

Activities

DenisChenu

DenisChenu

2016-04-23 12:14

developer   ~37735

No, tip must be shown by default, it's a misconcept to hide it.

Have more option, something for "Select one" , and some other for dybamic tip : why not. But tip must be shown.

You can use template.css to hide the tips you want.

tixeon

tixeon

2019-08-06 02:02

reporter   ~53119

I also want this. I always write my own instructions and I have never used the tip function. It is annoying to have to turn it off for literally every single question I program.
Maybe you can have it as an option in the global settings for the administrator (that is, I can choose to have tips hidden by default)

tammo

tammo

2022-05-21 19:38

partner   ~69958

I am also in favour of this, when needed, I write my own tip texts.

Could this be an option in the global survey configuration?

Show tips:
On/Off

DenisChenu

DenisChenu

2022-05-23 09:10

developer   ~69962

Theme options ?
Seems to be a really good idea !

need more option too

  1. Hidden when success (current situation)
  2. Hidden always
  3. Hidden always BUT : shown when user try to submit

See : https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla/-/blob/master/css/skelvanilla.css#L194-200

and what for sq_fn_validation and q_fn_validation : a separate settings ?

Else : it's really a Question attribute linked with Theme : See 14248: Allow survey theme to add (and use) question attribute feature request
https://bugs.limesurvey.org/view.php?id=14248

Issue History

Date Modified Username Field Change
2016-04-18 19:01 qualitatuvic New Issue
2016-04-23 12:14 DenisChenu Note Added: 37735
2019-08-06 02:02 tixeon Note Added: 53119
2022-05-19 18:20 ecoplan Issue Monitored: ecoplan
2022-05-19 18:20 ecoplan Bug heat 4 => 6
2022-05-21 19:38 tammo Note Added: 69958
2022-05-21 19:38 tammo Bug heat 6 => 8
2022-05-23 09:10 DenisChenu Note Added: 69962
2022-05-23 09:11 DenisChenu Relationship added related to 14248