View Issue Details

This bug affects 1 person(s).
 0
IDProjectCategoryView StatusLast Update
17161Bug reportsSurvey editingpublic2021-03-04 09:42
ReporterJmantysalo Assigned To 
PrioritynoneSeveritytweak 
Status confirmedResolutionopen 
Product Version4.4.7 
Summary17161: Setting question(s) mandatory from the question list broken
DescriptionFrom the question list the user can select one or several and click Selected question(s)... > Set "Mandatory" state. However, it does not work and also the error message fails to show corretly. Source code is shown to the user, it starts with

{"success":false,"message":"Property \"CDbCriteria.0\" is not defined.","error":{"code":500,"type":"CException",

For reference, for example Set statistics options seems to work, or at least it does not give error message.
Steps To Reproduce1. Create a survey with 1 question group and 2-3 questions.
2. From the Settings tab select "Question List" to display the list of questions.
3. Tick the box (at the beginning of each question) for all questions.
4. Click on the "Selected Question(s)" box at the bottom of the question list and select "Set Mandatory State".
5. Click "Yes" for Mandatory and "Apply" in the popup box.
Expected Results: Respondent should not be able to move forward without answering each question.
TagsNo tags attached.
Bug heat0
Complete LimeSurvey version number (& build)Version 4.4.9+210219
I will donate to the project if issue is resolvedNo
Browser
Database type & versionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-03-03 20:41 Jmantysalo New Issue
2021-03-04 09:42 vharris Status new => confirmed
2021-03-04 09:42 vharris Steps to Reproduce Updated View Revisions