View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
17650Bug reportsInstallationpublic2021-10-07 11:00
Reporteruibklime1 Assigned Toollehar  
PrioritynoneSeveritypartial_block 
Status acknowledgedResolutionopen 
Product Version3.25.20 
Summary17650: tutorial fubar'd. No admin. No Beginner Tour.
DescriptionThe tutorials function simply does not work. The "Default" tutorial should, I believe, populate the "tutorials" table, which is empty. I believe this results in the bug seen in 14786. Clicking on the pulldown just produces a reload. There is no administrative menu for the tutorial function. The "tutorial" admin verb redirects to a broken link. I believe there are several ROOT CAUSES here.

1. controllers/AdminController.php: getActionClasses() should return a key of 'tutorials' and not 'tutorial'

2. ./helpers/update/updatedb_helper.php:
       //Reset Surveymenues and tutorials to fix translation issues
        if ($iOldDBVersion < 346) {
            $oTransaction = $oDB->beginTransaction();
            createSurveyMenuTable($oDB);
            $oDB->createCommand()->truncateTable('{{tutorials}}');
            $oDB->createCommand()->truncateTable('{{tutorial_entries}}');
            $oDB->createCommand()->truncateTable('{{tutorial_entry_relation}}');
            $oDB->createCommand()->update('{{settings_global}}', ['stg_value'=>346], "stg_name='DBVersion'");
            $oTransaction->commit();
        }

or in 337...

The table is truncated. Where is it supposed to be populated? It never worked.
Steps To ReproduceSteps to reproduce
------------------------------
Click on Tutorials / Beginner Tour.

AND

Try to go to admin/tutorial or admin/tutorials

AND

Log messages (With debug) produce a message saying:
[application] Failed to set unsafe attribute "settings" of "Tutorial".

AND

Check contents of "tutorials" table on db

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)3.22.4, but problematic code in 3.27.19 is identical.
I will donate to the project if issue is resolvedNo
Browser
Database type & versionmysql 5.7
Server OS (if known)
Webserver software & version (if known)
PHP Versionphp-fpm 7.3

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

ollehar

ollehar

2021-10-06 12:32

administrator   ~66774

We removed this for LS5. Maybe remove it for LS3 too?
uibklime1

uibklime1

2021-10-07 10:02

reporter   ~66785

I wonder if it had been removed because no one used it *because no one could*?? The misspelling prevented the route from working in LS3. Just sayin'
ollehar

ollehar

2021-10-07 11:00

administrator   ~66786

For sure we removed it because it was too buggy and not tested enough.

Issue History

Date Modified Username Field Change
2021-10-06 03:51 uibklime1 New Issue
2021-10-06 12:32 ollehar Note Added: 66774
2021-10-06 12:32 ollehar Bug heat 0 => 2
2021-10-06 12:33 ollehar Assigned To => ollehar
2021-10-06 12:33 ollehar Status new => acknowledged
2021-10-07 10:02 uibklime1 Note Added: 66785
2021-10-07 10:02 uibklime1 Bug heat 2 => 4
2021-10-07 11:00 ollehar Note Added: 66786