View Issue Details

This bug affects 1 person(s).
 0
IDProjectCategoryView StatusLast Update
17786Bug reportsSurvey editingpublic2021-12-14 12:59
Reportermhladun Assigned Togalads  
PrioritynoneSeveritypartial_block 
Status acknowledgedResolutionopen 
Product Version5.2.x 
Summary17786: List of Active Surveys Not Updated After Deactivating Survey
Description

After deactivating an active survey, the list/count of "Active surveys" is not updated. Limesurvey thinks the survey is still active.

Steps To Reproduce

Steps to reproduce

  1. Activate a survey. Our initial "Active surveys" count is 1. See step_01.png
  2. Notice the survey is now activated. The "Active surveys" count has been incremented by 1, as expected. See step_02.png
  3. Go to the survey's general settings and find the "Stop this survey" button. Click it. "Active surveys" is 2, as expected. See step_03.png
  4. You should be shown a warning about deactivating a survey. "Active surveys" is still 2, as expected. Click "Deactivate survey". See step_04.png
  5. The message "survey was deactivated." is displayed, however, "Active surveys" is still 2. See step_05.png
  6. We find, when going to the survey's general settings afterwards, that we're shown the "Stop this survey" button. See step_06.png
  7. To fix this, we navigate to Configurations -> data integrity and are told "Some automatic fixes were already applied." See step_07.png

Expected result

  1. "Active survey" count is decremented by one when deactivating a survey.
  2. The list of surveys is accessible and works.
  3. Our deactivated survey doesn't have a "Stop survey" option after it is deactivated.

Actual result

  1. "Active survey" count remains constant.
  2. The list of surveys is not accessible and an error page appears. See ls_error.png
  3. Our deactivated survey does have a "Stop survey" option after it is deactivated.
TagsNo tags attached.
Bug heat0
Complete LimeSurvey version number (& build)5.2.2+211115
I will donate to the project if issue is resolvedNo
BrowserBrave/Chrome
Database type & versionPostgresql/EnterpriseDB 10.9.17
Server OS (if known)Windows Server 2019 Datacenter
Webserver software & version (if known)nginx 1.20.1/php-cgi
PHP Version8.0.12

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

mhladun

mhladun

2021-12-07 19:53

reporter  

ls_error.png (47,657 bytes)   
ls_error.png (47,657 bytes)   
step_01.png (63,154 bytes)   
step_01.png (63,154 bytes)   
step_02.png (82,210 bytes)   
step_02.png (82,210 bytes)   
step_03.png (11,923 bytes)   
step_03.png (11,923 bytes)   
step_04.png (72,163 bytes)   
step_04.png (72,163 bytes)   
step_05.png (67,126 bytes)   
step_05.png (67,126 bytes)   
step_06.png (11,841 bytes)   
step_06.png (11,841 bytes)   
step_07.png (9,417 bytes)   
step_07.png (9,417 bytes)   

Issue History

Date Modified Username Field Change
2021-12-07 19:53 mhladun New Issue
2021-12-07 19:53 mhladun File Added: ls_error.png
2021-12-07 19:53 mhladun File Added: step_01.png
2021-12-07 19:53 mhladun File Added: step_02.png
2021-12-07 19:53 mhladun File Added: step_03.png
2021-12-07 19:53 mhladun File Added: step_04.png
2021-12-07 19:53 mhladun File Added: step_05.png
2021-12-07 19:53 mhladun File Added: step_06.png
2021-12-07 19:53 mhladun File Added: step_07.png
2021-12-14 12:59 galads Assigned To => galads
2021-12-14 12:59 galads Status new => acknowledged